IPD sale XeMODeX - Experts in Volvo Electronics

Search found 0 matches

by Vtech
Wed Nov 21, 2012 5:02 pm
Forum: Volvo 850, S70, V70, C70, XC models 1992-2000
Topic: S70 not accelerating
Replies: 5
Views: 1673

Re: S70 not accelerating

Hello , it sounds like your transmission is slipping , please check the fluid level before driving any more and if it is low top it up before driving . see owners manual for proceedure . If fluid is dark or black then drain and refill - takes 3.5 - 4qts . should use volvo fluid or good quality synth...
by Vtech
Mon Apr 30, 2012 11:00 am
Forum: 240, 740, 760, 780, Bertone, 940, 960, V90, S90
Topic: New 740 GL Owner with starting problem
Replies: 8
Views: 1381

Re: New 740 GL Owner with starting problem

code 321 From socket #2 is for cold start injector circuit . below around 58 deg f pcm gives a couple sec ground to cold start injector under intake . supression relay supplies bat+ to injector . as Thinker said loose connection can cause your problem , should still start fine above 60deg f . cold s...
by Vtech
Thu Apr 26, 2012 3:20 pm
Forum: 240, 740, 760, 780, Bertone, 940, 960, V90, S90
Topic: New 740 GL Owner with starting problem
Replies: 8
Views: 1381

Re: New 740 GL Owner with starting problem

Hello , did you see if the injectors are clicking , listen with a screwdriver on the injector and your ear on the handle while someone cranks the engine . If no clicking , disconnect one injector connector and see if there is power at the green wire when cranking , if not the radio supression relay ...